Overview:
A User is receiving an error in the user's Activity Logs: Sync Failed: Refresh unsuccessful. This occurs when syncing with an error: No viable alternative at character.
Root Cause:
The error: no viable alternative at character, is caused by a bad character in the Vmobile Object Configuration (VMOC).
Solution:
Review the VMOC of the object which is receiving the error. Remove any double-quotes from the Where Clause.
Example error from the Activity Logs:
- FROM Attachment WHERE Name like "Signature_Graphic%" ^ERROR at Row:1:Column:197line 1:197 no viable alternative at character '"'
- Review the Attachment objects VMOC Where clause: WHERE (Name like "Signature_Graphic%").
- Update the Where clause text to: WHERE (Name like 'Signature_Graphic%').
Related Documentation:
CRM Help Documentation: Using VMoble Object Configurations