Overview:
A user no longer has Send As Link available.
Root Cause:
This is due to the feature View User Information, which is a flag on the user's Permission Set. To be able to use Send As Link, the View User Information setting needs to be enabled.

Other features that are affected are:
- Timeline View (in the Doc Info page)
- Delegate Access (in the User Profile page)
- Sharing Settings (in the Action menu or Doc Info fields)
- Edit Sharing Settings (in Bulk Document Actions)
- Search and filters that are related to user information (in Search, Advanced Search, Library, and custom tabs)
Solution:
- Navigate to: Admin --> Users & Groups --> Permission Sets.
- Click the Application tab.
- Click Edit.
- Scroll down to User.
- Enable the View User Information flag.