Overview:
A user creates an Alert that is visible for only one profile by entering the name of the profile into the Profile field. When the Alert record is saved, an error message appears: Could not Determine the Salesforce profile associated with this record.
Root Cause:
Profile Name cannot be used in Alerts.
Solution:
The Profile field needs to be populated with the profile’s 18-digit (Salesforce.com) SFDC ID or a profile picklist needs to be configured.
Related Documentation:
CRM Help Documentation: Enable Alert Profile Picklist
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