Overview:
A confirmation message is set in the Event_Action_vod.Confirmation_Message_vod__c field but it is not displaying.
Root Cause:
The Event_Action_vod.Confirmation_Message_vod__c field is used to store the name and category of a Veeva Message. If populated, the value in the text field from this Veeva Message displays when the Event Action is executed. The format for this field uses the Name and Category of the Veeva Message as well as the following syntax: Name;;Category. Customers can create new Veeva Messages to support the confirmation messages that is displayed.
Solution:
There are two possible solutions to have the Confirmation Message display:
- Create a Veeva Message and change the text of the Veeva Message to match the confirmation message. Change the Confirmation Message field to point to the Veeva Message using the syntax Name;;Category.
- Use the Page Layout Organizer to create the Veeva Message for you. Documentation for the Page Layout Organizer can be found below.
Related Documentation:
CRM Help Documentation: Page Layout Organizer