Overview:
An end-user sends an Approved Email to an Health Care Provider (HCP). When the HCP clicks on the hyperlink, an error occurs: The survey is currently not available. Please try again later.
Root Cause:
The error occurs when the Survey Integration user has Field Level Security (FLS) missing for the Question_Number_vod__c field in the Survey_Question object.
Solution:
Add FLS to Question_Number_vod__c.Survey_Question_vod by following these steps:
- Navigate to the User Detail page of the user.
- Click on the Profile link in the Profile field.
- Navigate to the Survey Question object in the Custom Object Permissions section.
- Be sure the user has permission on the Question_Number_vod__c.Survey_Question_vod field.
Related Documentation:
CRM Help Documentation: Surveys in Approved Email