Overview:
A customer has some Accounts in the organization that do not inherit the Address of a parent. Address Inheritance does not create or update the Address Records in CRM Online.
Root Cause:
For Address inheritance, there are two main criteria that have to be met when the batch is run:
- Copy Address is enabled (checked) on the Child Account record
- Last Address Run Custom Setting has to be an earlier date or time that the Parent addresses Last Modified By
When the address inheritance batch is run, it can do the following:
- Update the Last Modified By field on the Parent Address
- Copy the New Address on the inherited Account
- Update the existing Child Records
Solution:
To run the Job directly from the Developer Console using a System Administrator profile:
- Go to the username in the top-right corner of the UI.
- Navigate to: Developer Console --> Debug.
- Open the Execute Anonymous Window.
- Paste the code of the Apex Class (EXAMPLE_FOR_ADDRESS_PUSH_SCHEDULING) responsible for Address Inheritance:
Code:
VEEVA_BATCH_CHILD_ACCOUNT_PUSH b = new VEEVA_BATCH_CHILD_ACCOUNT_PUSH();
database.executebatch(b,10);
VEEVA_BATCH_CHILD_ACCOUNT_DELETE c = new VEEVA_BATCH_CHILD_ACCOUNT_DELETE();
database.executebatch(c,25);
- Review Setup --> Apex jobs to see when they complete.
- In the Developer Console, the batch generates extra log files with details.
- Schedule the Apex Class from Schedule jobs.
Related Documentation:
- CRM Knowledge Article: Address Inheritance Does Not Copy Address
- CRM Help Documentation: Address Inheritance Support