Overview:
When users save Business Reply Card (BRC) samples to Call, an Address to ship to can be selected. Once the Signature is captured on the Call and the Call is saved or submitted, the Ship to Address or Ship License fields are blank.
Root Cause:
This is caused by an invalid configuration. The user is missing Edit access to the fields that store the shipping information on the Call record.
Solution:
Grant Edit access to the following fields on the Call2_vod object for all users who make BRC calls:
- Ship_Address_Line_1_vod
- Ship_Address_Line_2_vod
- Ship_City_vod
- Ship_Country_vod
- Ship-To DEA fields (optional)
- Ship_License_vod
- Ship_License_Expiration_Date_vod
- Ship_License_Status_vod
- Ship_State_vod
- Ship_Zip_vod
- Ship_Zip_4_vod
The users also must have Read access to the Ship_To_Address_vod field on the Call object. This is a lookup field representing the Address selected for shipping. The values from this Address are used to stamp the Ship Address and License fields above at the time the Signature is captured on the Call.
Related Documentation:
CRM Help Documentation: Configuring Sample Requests (BRCs) for Users