Overview:
CRM Configurable Lookup filter to a supported object is not working properly as it displays all values.
The configuration appears to be correct and the Metadata Cache Manager tab shows the appropriate Lookup Filter. The Supported column lists true.
Root Cause:
The end-user does not have Read Field-Level Security (FLS) to the field involved in the rule.
Solution:
Grant FLS Read access to the end-user for the fields referenced in the Lookup filter.
Related Documentation:
CRM Help Documentation: Configurable Lookup Filters and Layouts