Overview:
When the user clicks the Save button in the BEE email editor, the email template cannot be saved with the error: Saving template failed.
Root Cause:
The following permissions should be granted to the user role for using the BEE email editor in the current state of the Approved Email lifecycle:
- Edit Fields
- Edit Document
- Version
Solution:
Please follow below steps to add the required permissions for the user.
- Go to Admin --> Configuration --> Document Lifecycles --> Approved Email --> States.
- Click the current state of the email template (In this example: Draft) and click the Security Settings tab.
- Click the Edit button and select the Edit Fields, Edit Document and Version permissions.
- Save the changes.
If the above access is granted to the user and the issue persists, please contact Product Support to ensure the Approved Email feature is enabled for your Vault.
Related Documentation:
Vault Help Documentation: Related Permissions