Overview:
Salesforce Territory rules are not working with an Account Record Type criteria. When the admin user clicks on the Run Rules button, the Salesforce Territory Alignment does not follow the Account Record Type Rule Criteria.
Root Cause:
The Label of the Record Type is translated in the Admin User's language. In order to run the Territory Alignment correctly on an Account Record Type criteria, the translated Record Type Label and Record Type Name need to be matched.
Solution:
The translated Account Record Type Labels can be checked in the following way:
Navigate to: Setup --> Translation Workbench --> Translate --> Admin User's language --> Record Type Setup component --> Account Object --> Field Label Aspect.
The Record Type Label Translation column needs to be blank or have the exact same value of the Master Record Type Label.
Related Documentation:
SFDC Help Article: How Account Assignment Rules Work