Overview:
A user creates a Contract Template using a custom Contract Record Type.
When clicking on the New Contract button on an Account record, the Contract Template is not available under Templates.
Root Cause:
A custom Record Type is missing on the Contract Partner and Contract Line objects.
Solution:
If a custom Record Type is created on the Contract object, the exact same Record Type needs to be created on the Contract Partner and Contract Line objects as well.
- Under Setup --> Create, navigate to the Contract Partner and Contract Line objects.
- Scroll down to the Record Types section.
- Click on the New button.
- Create Record Types with the exact same name as the Record Type name on the Contract object.
- Be sure to enable the newly created Record Types for the user profile:
- On the User Detail page, click on the Profile link in the Profile field.
- Scroll down to the Record Type Settings section.
- On the Contract Partner and Contract Line objects, move the new custom Record Types to Selected Record Types.
Related Documentation:
CRM Help Documentation: Contract Templates
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