Overview:
The Salesforce Username field is used to associate the user with a Salesforce.com or Veeva CRM user account for delegated authentication. However, the admin cannot find this field in the User Details page layout to update.
Root Cause:
This field is only available if the selected security policy allows login via salesforce.com.
Solution:
To make the Salesforce Username field display in the Page Layout requires the user has Domain Admin access. Do the following:
- Go to Admin --> Settings --> Security Policies --> [Security Policy]
- Click the Edit button.
- Select Allow login using Salesforce.com.
- Enter the Salesforce Organization Id.
- Click Save.
Related Documentation:
Vault Help Documentation: