Overview:
Even though there is only one product assigned to the user, a Javascript method getProduct_MySetup(type, callback) returns all the products in CRM iRep when developing HTML5 content that interacts with the Veeva CRM database.
Root Cause:
One reason for this problem is there is one record incorrectly loaded into the My Setup Products object. For this record, there is no product specified in the Product_vod__c field.
Solution:
Remove the incorrect record from the My Setup Products object.
Related Documentation:
CRM API Reference: getProduct_MySetup(type, callback)
Thank you