Overview:
There is a custom field that cannot be found in the available columns when creating or editing a report. This makes it impossible to report on that field.
Root Cause:
The default Field Level Security (FLS) of that custom field is Hidden.

Solution:
In order to open the report, an admin is required to do the following:
- Go to Admin --> Configurations --> Document Fields --> [Document Field].
- Click Edit button.
- Update the Default Security from Hidden to others.

- Or, the admin can add a Security Override, which is not Hidden, to the expected users who have access to open that report.

Related Documentation:
- Vault Help Documentation: Types of Field-Level Security
- Vault Article: Error: Error processing this report because it references inaccessible field(s) - When Opening a Report in Vault