Overview:
Validation rules are configured for the Medical Inquiry object. No entry is made in the Validation Rule Administration tab. Validation Rules work for online users and do not work for Offline users.
Root Cause:
Veeva does not deliver a VMobile Object Configuration (VMOC) for Medical_Inquiry_vod as part of a standard implementation. Instead, Veeva relies on the include related objects setting in the Account VMOC. If including Validation Rules on Medical_Inquiry_vod as required, creating a VMOC for this object is necessary.
Solution:
- Create a new, standard VMOC for the Medical_Inquiry_vod object with Type set to Full Sync. Adding a WHERE clause is not necessary.
- From the Validation Rule Administration tab, click the Refresh Validation Rule Data button.
- Have users re-sync offline devices to download the configuration changes.
Related Documentation:
CRM Help Documentation: Offline Validation Rules
Knowledge Article: CRM Object is Not Appearing on the Validation Rule Admin Page