Overview:
Network Account Search (NAS) returns an error: User does not have permissions for the submitted Country in Veeva Network. This occurs when a user tries to add an Account to a Territory even when the user's Country is set correctly and the affected Country is mapped in the Network Administration object.
Root Cause:
A Data Visibility Profile is missing from the Network Integration user's profile.
Solution:
A Veeva Network Admin user needs to review the Data Visibility Profiles of the Integration User, to be sure all Countries are included and are mapped in the Network Administration object in CRM.