Overview:
There are old records in the Recycle bin. The Salesforce Sweeper Process failed to permanently delete these records due to their age. The process normally hard-deletes soft-deleted records that are not updated for more than fifteen days.
Root Cause:
When deleting multiple records at once, the queue grows too large for the Sweeper Process to delete all the records in one evening. This extends the time over multiple weeks or even months.
Solution:
After cleaning up large amounts of data in an org, empty the Recycle bin and open a ticket with Veeva Support. Support notifies Salesforce to run the physical delete process in an environment to permanently delete the data.
Related Documentation:
Salesforce Help Documentation: Deleting Data
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