Overview:
The CRM Validation Rule works Offline but not Online.
Root Cause:
The Validation Rule contains ISNULL(TEXT(Picklist_Field__c)).
ISNULL determines if an expression is null (blank) and returns TRUE if it is. If it contains a value, this function returns FALSE.
Solution:
Change the Validation Rule to use ISBLANK(TEXT(Picklist_Field__c)).
ISBLANK determines if an expression has a value and returns TRUE if it does not. If it contains a value, this function returns FALSE.
It is important to use ISBLANK instead of ISNULL in new formulas. ISBLANK has the same functionality as ISNULL, but also supports text fields.
Related Documentation:
- SFDC Help Documentation: Formula Operators and Functions
- CRM Help Documentation: Offline Validation Rules
Send us your feedback: We're always looking for advice to help improve our Knowledge Base! Please let us know if this article was helpful or provide feedback on how we can improve your experience here.