Overview:
An Email Template has the field Approved_Document_vod.Allowed_Document_IDs_vod
populated with the IDs of fragments that should be usable with this template; however, when the end-user clicks Add Documents while sending an Approved Email, all visible fragments are available for selection.
Root Cause:
The end-user is missing Read field level security to the Approved_Document_vod.Allowed_Document_IDs_vod field.
Solution:
Add Field Level Security (FLS) to the Approved_Document_vod.Allowed_Document_IDs_vod field at either the Profile or Permission Set level.
If using a profile to assign security:
- Log into the Org as an Administrator.
- Navigate to: Setup --> Administration Setup --> Manage Users --> Profiles.
- Drill into the correct Profile.
- Scroll-down to the Field Level Security (FLS) section of the Profile.
- Click View next to Approved Document.
- Click Edit.
- Grant Read access to the Allowed Document IDs field.
- Click Save.
- Clear the Veeva Cache.
If using a permission set to assign Security:
- Log into the Org as an Administrator.
- Navigate to Setup -->Administration Setup --> Manage Users --> Permission Sets.
- Drill into the correct Permission Set.
- Drill into Object Settings.
- Drill into the Approved Document object.
- Click Edit.
- Grant Read access to the Allowed Document IDs field.
- Click Save.
- Clear the Veeva Cache.
Related Documentation:
CRM Help Documentation: