Overview:
When viewing a MyInsights HTML Report in Veeva CRM for iPad, the report is displaying ??? characters inside standard text labels:
Typically, the labels will display actual text rather than just question marks.
Root Cause:
The standard MyInsights HTML Reports utilize Veeva Messages to populate some of the text fields. This is to allow easy customization and translation of the various components.
These FieldReporting Veeva Messages are missing for the user's defined language.
Solution:
Clone the Veeva Messages with a FieldReporting category for the affected user language. All user languages that have access to the MyInsights HTML Reports should have Veeva Messages.
For example - the Territory Insights Report:
- Locate the CALL_ACTIVITY Veeva Message.
- Select Clone and set the Language as the user's configured language.
- Change the External ID to identify as the new language.
- Confirm the Text value is correct.
- Save the Veeva Message.
- Sync the user.
The user's MyInsights Territory Insights Report should now have a properly populated Call Activity text label.
Related Documentation:
Knowledge Base: How to Change MyInsights Veeva Messages in CRM?