Overview:
A Custom My Account View is displaying zero results for a select group of users.
Root Cause:
When a Custom My Account View displays zero results for users of the same profile then the issue is in the built Query.
Solution:
Review the Query of the View record. In a review of the Query check to ensure the user has Field Level Security for all fields, Record Type Access, and any other special requirements used.
Related Documentation:
CRM Help Documentation: My Accounts