Overview:
Online CRM users are able to see all of the Office Best Times section, but Veeva CRM for iPad (iRep) shows a smaller version of the section.
Root Cause:
In iRep, the Office Best Times S-control automatically expands to the width of the column for the section of the layout that it has been placed in.
Solution:
On the Address layout, for the appropriate record type, edit the Section Properties and check the radio button for 1-Column in the Layout section.

Related Documentation:
CRM Help Documentation: N/A
Thank you