Overview:
The SCHEDULER_FILTER is not displaying new field in CRM online. For example, the Veeva Setting SCHEDULER_FILTER is set using: ACC.Name, ACC.Account_identifier_vod__c, ADD.Zip_vod__c, and ADD.Name
The filter appearing on My Schedule page is shown below. The field Account_identifier_vod__c is not displayed.
Root Cause:
The Veeva Setting, SCHEDULER_FILTER, is case sensitive.
The field Account_identifier_vod__c API Name is not recognized. It should use an uppercase I in the name: Account_Identifier_vod__c
Solution:
Change the value of the Veeva Setting SCHEDULER_FILTER with the field API name using the correct letter case.
Related Documentation:
CRM Help Documentation: Scheduler Filters in My Schedule
Thank you