Overview:
Users are unable to select the Ship To Location but are able to select the Ship To Address for a Business Reply Card (BRC) sample added to a Call.
Root Cause:
In order to view Ship To Locations other than the primary address of the Account, there must be a child Account record for the Primary and Child Account. The user must have Read permission to the Child Account object.
Solution:
Ensure that the user has Read FLS to the Child_Account_vod object and, if missing, create a Child Account record between the person Account and the parent Account.
Related Documentation:
CRM Help Documentation: Ship to Business Location