Overview:
The CLM Administration Console displays the following error after a sync:
Clm_Presentation_vod__c is missing access on following required fields: Vault_Doc_Id_vod__c,Vault_DNS_vod__c,Vault_External_Id_vod__c,Vault_GUID_vod__c,Vault_Last_Modified_Date_Time_vod__c,Version_vod__c,VExternal_Id_vod__c
The administrator changes the Field-Level Security (FLS) for the CLM Integration User to correct this, but it is still running into the issue.
Root Cause:
The Vault to CRM mapping is not refreshed:
Solution:
When permissions are changed on the CLM Presentation, CLM Presentation Slides, and Key Messages objects for the CLM integration user, the Vault to CRM mapping should be refreshed. This is done using the View Map --> Compare CRM to Vault option on the CLM Admin Console.
Related Documentation:
CRM Help Documentation: Integrating CRM and Vault for CLM