Overview:
When an end-user clicks on the New button in My Accounts, the Network Account Search (NAS) returns an error message: 500 Servlet Exception as shown below:
Root Cause:
The end-user is not assigned to any Territories.
Solution:
An Admin user needs to assign a Territory to the end-user using the following steps:
- Log into the CRM org as an Admin user.
- Click on Setup.
- Click on Territory Hierarchy under Manage Territories.
- Select the Territory the user needs to be assigned to.
- Click on the Add Users button.
- Select the user that needs to have that Territory.
Once the Territory is assigned, the Network Account Search can be initiated, and the results are displayed according to the Territory set for the user.
Related Documentation:
CRM Help Documentation: