Overview:
The Key Messages and CLM Media section (zvod_CLMDetails_vod__c) of Call Reporting is configured on the Page Layout. However, this functionality is not working on Veeva CRM for Windows or iPad. After viewing a presentation, the Call Reporting page displays but the CLM Media section is missing. No media message is displayed.
Root Cause:
The user is missing Field Level Security (FLS) Edit access on the Add_Key_Message_vod__c field on the Call2_vod__c object. The Offline applications require that the users have access to this field in order for the zvod_CLMDetails_vod__c section to function.
Solution:
Perform the following steps:
- Navigate to the user's profile.
- Find the FLS section and select Call (Call2_vod__c).
- Provide the user with FLS Read and Edit access to the Add Key Message field.(Add_Key_Message_vod__c).
- Clear the Veeva Cache.
- Sync the User.
Related Documentation:
CRM Help Documentation: Key Messages