Overview:
The My Accounts views are not displaying after loading new views or making changes to the Criteria_vod__c and Statement_vod__c. The columns show but no Accounts display in the views.
Root Cause:
When adding criteria to a view, the UI updated both the Statement_vod__c and the Criteria_vod__c fields. When loading new views or making changes to current views using dataloader, both the Criteria_vod__c and Statement_vod__c must contain the same criteria.
Solution:
Review the view using Dataloader or Workbench to be sure the Statement_vod__c contains all of the criteria from Criteria_vod__c.
Editing the view from the UI refreshes both the Criteria_vod__c and Statement_vod__c so they match.
Related Documentation:
CRM Help Documentation: CRM Help