Overview:
Users are able to Create Response from a Medical Inquiry Fulfillment in which they can create and submit a Call. The Medical Inquiry Fulfillment does not get updated with the Medical Inquiry record ID and the Status is not updated to Completed.
Root Cause:
The Medical_Inquiry_Fulfillment_vod is not on the page layout or the user does not have access to it. This field is on the Medical Inquiry Fulfillment page layout by default. Admins can place it on any other page layout used for responding to Medical Inquiries, if needed.
Solution:
Grant users Field Level Security (FLS) Edit permission to the Zvod_medical_inquiry_vod field on the Call2_vod object.
Related Documentation:
CRM Help Documentation: Medical Inquiry Fulfillment