Overview:
The Approved Emails Invitation icon is not displayed when making an Engage Meeting Call, even though the configurations have been set.

Root Cause:
Approved Documents, whose record type is Remote_Meeting_vod, do not exist in the CRM. Or users do not have Read access to Approved Documents.
Solution:
Be sure users have Read access, at a minimum, to at least one Approved Document of record type Remote_Meeting_vod.
Related Documentation:
CRM Help Documentation: Engage Meeting Overview