Overview:
A document is added to the email fragment by using the {{PieceLink}} token. It is sent to the Account. However, the Account cannot open the document.
Root Cause:
The document is not added to the Related Pieces section.
Solution:
Add the document to the Related Pieces section.
The {{PieceLink}} token expands to a URL pointing to a Vault document of type: Promotional Piece.
Related Documentation:
CRM Documentation: Approved Email Configuration Tokens