Overview:
Scheduling Approved Emails did not send although the status is Scheduled_vod.
Root Cause:
The end-user or the integration user does not have Field-Level Security (FLS) on the Scheduled_Send_Datetime_vod field on the Sent_Email_vod object.
Solution:
To enable the Scheduling Approved Email feature, grant the end-users and the integration user FLS Edit permissions to the Scheduled_Send_Datetime_vod field on the Sent_Email_vod object.
Related Documentation:
CRM Help Documentation: