Overview:
The document is added to the email fragment by the {{$VaultDocID}} token. It is sent to the Account. However, the Account cannot open the document.
Root Cause:
The document is not added to the Other Related Documents section.
Solution:
Add the document to the Other Related Documents section.
The content admin can include any Vault PromoMats document in an email. However, it requires a special syntax which expands to a URL pointing to a Vault PromoMats document of any type. This requires the Vault document ID as an argument. In order to use this token, the document is added to the template or fragment as other related documents. For example, {{$20}} points to Vault document ID 20.
The document number is visible in the URL when viewing a Vault document. It is not visible from the General Properties page sidebar. The integer to the right of #doc_info is always the unique Vault document ID.
Related Documentation:
CRM Documentation: Approved Email Configuration Tokens