Overview:
A newly created Account in iRep is unable to be selected as a Primary Parent without syncing first.
Root Cause:
The decoupled Data Change Request (DCR) feature is not configured correctly.
Solution:
Correct the issue by following these steps:
- Set the Data Change Request under Veeva Settings to 0 instead of blank.
- Profiles should not have Field Level Security (FLS) to the CUSTOMER_MASTER_STATUS field on the Account Object. This is a field used when the CRM org is integrated with Network and is irrelevant if the Customer is not a Network customer.
Related Documentation:
CRM Help Documentation: Decoupled Data Change Requests