Overview:
When running the Account Summary report from an Account, the Sales Detail All row does not match the Product rows sum.
Root Cause:
The All Total lists the total for All products in the Market. It does not list the sum of the selected Display Products.
Solution:
Select every Display Product in the Market to compare with the All Total line. It is not possible to show a total line for only the selected Display Products.
Related Documentation:
CRM Help Documentation: Viewing the Account Summary Report