Overview:
A Survey Target record is submitted without Question Response records.
Root Cause:
This occurs when the user is missing the Survey_Question_vod__c records related to the Survey Offline, and none of the Survey_Question_vod__c records are marked as required. The most common reason for the Survey_Question_vod__c records to be missing is a timing issue between the time when the user syncs and when the records (and related records) are last updated.
Solution:
Be sure there is an active Vmobile Object Configuration for the Survey_Question_vod__c object. Be sure that Enhanced Sync is turned on for the Survey_Question_vod__c Vmobile Object Configuration. This ensures that the records, which the user has access to, sync offline.
Related Documentation:
CRM Help Documentation: Survey Overview
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