Overview:
A user cannot complete a task for a workflow with error message: User task assignee group must contain users. There is an issue for Participants in a subsequent workflow step.
Root Causes:
- The role assigned to the participant group in the workflow start step does not have a user assigned to the role in the record's sharing settings.
- The user assigned to the role does not have a permission set with the Application --> Workflow --> Participate permission.
- The original user is assigned to the related role A, but now the user is inactive. The only way to change this user is through the Replace Participant action. Sharing settings are used to control access to the Document and its attributes, while workflow Roles are used to control who can receive or perform tasks.
It is intentional for the Workflow to have its own listing of users per role so that access to the document is not altered once a workflow is started. Only certain actions such as Replace or Add Participant and Reassign task can be used to alter the Workflow Participant roles. These update the Sharing Settings automatically.
Therefore, changing the user through the Sharing Settings manually does not impact the user in the Workflow.
Solutions:
- Assign a user to the Lifecycle role that is set for the workflow participant group.
- The role should have a permission set with the Application --> Workflow --> Participate permission.
- Use the Replace Participant action to replace the original user to another active user. Have the assigned user complete the task again.
Note: The user may have to make the inactive user active again to be able to successfully use the Replace Participant action. If that is the case, make the user active again. Carry out Steps 1 and 2 and then make the user inactive again.
Related Documentation:
Vault Help Documentation: Managing Active Document Workflows