Overview:
When a user is recording an Inventory Monitoring Online or Offline, the following error message occurs: Insufficient access rights on cross-reference id.
Root Cause:
That is due to Territory Settings assigned to the user.
Setting | Description |
Account Access | Users in this territory can view accounts assigned to this territory. |
As there is a Master-Detail relationship between Account and Inventory Monitoring, users assigned to that Territory need View and Edit permission.
Solution:
To enable View and Edit permission for the User's Territory:
- Navigate to Setup --> Manage Territories --> Territory Models.
- Select the Territory Name assigned to the user.
- Select Edit.
- In Account Access section select: Users in this territory can view and edit Accounts assigned to this Territory.
- Select Save.
- Clear the Veeva cache.
Related Documentation:
CRM Help Documentation: Inventory Monitoring