Overview:
It is not possible to choose Time or Datetime fields to display in Salesforce Reports.
Root Cause:
Only the Created Date and Last Modified Date fields are available. Time or Datetime fields are not supported.
Solution:
A workaround for this is to create a Datetime formula field and insert CreatedDate in the formula wizard. The new Datetime formula field is accessible in the reports.
Related Documentation:
Salesforce Documentation: Include Created Date AND TIME in Lead History Reports
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