Overview:
Why are Dismissed Alerts not being removed from iRep on an Incremental Sync?
Once a Signature is captured, the Alert expires. The user can also manually dismiss the Alert which expires the alert. The VMobile Object Configuration (VMOC) Where Clause excludes Expired Alerts from syncing down.
The user performs an incremental sync but the dismissed Alerts are still visible Offline. If the user performs a Refresh Database, the alerts are removed.
Root Cause:
While the Out-of-the-Box (OOTB) Alert VMOC excludes new records from syncing down, it does not remove all records, corresponding content, or attachments which the user no longer has access to or are excluded from the Where Clause.
The OOTB Alert VMOC Where Clause is:
Where Activation_Date_vod__c <= TODAY AND Expiration_Date_vod__c > TODAY
Solution:
Enable Enhanced Sync for the Alert VMOC.
Related Documentation:
CRM Help Documentation: