Overview:
When user clicks New Order, an error appears: This Account cannot create orders.
Root Cause:
This error occurs because the Order Record Type labels (NOT the Translations) are different from the Order Record Type API name.
Solution:
Change the Record Type Labels of the custom Order Record Type to match the Record Type Names.
Related Documentation:
CRM Help Documentation: N/A
Send us your feedback: We're always looking for advice to help improve our Knowledge Base! Please let us know if this article was helpful or provide feedback on how we can improve your experience here.