Overview:
Sometimes there is a need to immediately find matching documents and update counts or completeness for a specific Expected Document List (EDL) item. To do this, use the Match Documents option from the EDL Item action menu. However, after executing the Match Documents action, an error occurs: The defined matching criteria can no longer be found on this EDL Item.

Root Cause:
Vault matches documents to EDL Item records based on the Matching EDL Item Fields setting for the parent EDL record. The name of the Matching EDL Item Field (filling_level_c) in the parent EDL record is not matched with the name of picklist field itself (level_c).


Solution:
- Navigate to: Admin --> Business Admin --> Picklist --> [Target Picklist] with Edit mode.
- Update the name same as Matching EDL Item Field in the parent EDL record.
