Overview:
The user loads Survey Target records with specific owners. Why are the owners changed after the Survey is published in CRM Online?
Root Cause:
Assignment Rules determine the ownership of Survey Target records for targeted Accounts after a Survey is published.
If there is more than one active user matching the Assignment Rules, the system selects the first active user retrieved as the owner of the Survey Target record. This is regardless of whether there is an owner specified when the Survey Target record is loaded.
Solution:
There is a field named No_Autoassign_vod__c on the Survey Target object. If this field is checked (enabled), the publishing process does not change the owner of the record.
Related Documentation:
CRM Help Documentation: Adding Assignment Rules to SurveysSend us your feedback: We're always looking for advice to help improve our Knowledge Base! Please let us know if this article was helpful or provide feedback on how we can improve your experience here.