Overview:
The Approved Email sync fails with the error: Vault API call failed. Vault transaction id: Not available response status: FAILURE error type: INVALID_DATA cause: Unknown field 'tag__c' in 'field list' - Error querying all available approved content for url: select territory__v,crm_survey1__v...
Root Cause:
The Vault integration user does not have read permission to the field which appears in the error message of the Email Template Document Type.
In this case, the integration user who is in the Cholecap Group cannot see the tag field.
Solution:
The Vault Owner needs to use the steps below to resolve this issue:
- Navigate to: Admin --> Configuration --> Document Fields --> Email Template.
- Find and click the tag field.
- Click the Security Overrides tab.
- Click the Edit button --> + button.
- Grant the Vault Integration User read permission to the tag field.
- The CRM Admin implements the Incremental Refresh or Force Full Refresh in the CRM Approved Email tab.
Related Documentation:
N/A