Overview:
The approved email template cannot be synced from Vault to CRM with the error: Product: xxxxxxx referenced by document id: xxx is missing from Vault and/or Vault Integration User does not have access to it in Vault: https://xxx-xxx-xxx.veevavault.com
Root Cause:
The Vault integration user does not have Read permission to the product record which is used in the email template.
Solution:
The Enable Custom Sharing Rules option in the Product object detail page is selected. The Vault integration user does not have Read permission to the Product object according to the Sharing rule setting. This leads to the sync error.
The user can confirm the Sharing rule setting of the Product object by navigating to: Admin --> Configuration --> Objects --> Product --> SharingRules.
- Navigate to: Admin --> Business Admin --> Products --> Cholecap --> Sharing Settings.
- Click the Add button and provide the Vault integration user Read permission in the pop-up window.
Related Documentation:
N/A
Thank you