Overview:
A customer updates an Address record on the Parent Account and modifies the value to null.
In one of the fields where inheritance should occur, the value deletion is not reflected in the corresponding field of the Child Account Address.
Fields that are updated or populated are copied over, but fields, where the value is deleted, are not.
Root Cause:
This is an expected behavior. If any fields have a null value, the address field does not get copied to the child record.
Solution:
A validation rule can be created to prevent entering null values.
If copying the null value is what is expected, submit an Enhancement Request on the Community Portal to add this functionality.
Related Documentation:
CRM Help Documentation: Enabling Address Inheritance Support