Overview:
MySchedule page loads, however, the Bookmarks section is not displayed. The user profile has Full CRUD (Create, Read, Update, Delete) permission on the Bookmark_vod object and all Record Types are assigned.
Root Cause:
The SCHEDULER_FILTER_vod Veeva Setting is not populated.
Solution:
In addition to the CRUD permission to the Bookmark_vod object and access to all Bookmark_vod Record Types, the SCHEDULER_FILTER_vod Custom Setting needs to be populated with a comma-delimited list of the API Field Names for filtering.
Without the SCHEDULER_FILTER_vod populated, the bookmark does not appear.
Related Documentation:
CRM Help Documentation: Setting Bookmarks in Classic Cycle Plans