Overview:
When clicking the Print View link at the top-right of a page, not all information appears in the generated view pdf.
Root Cause:
When using the standard Print Preview button, Visual Force (VF) component details do not show up on the preview. When Print Preview is clicked, it only renders the current page and does not render related components. For example: The Key Message section does not appear on a Call Report when viewed in printable view.
Solution:
This is working as designed by SFDC, customization is needed for different behavior.
Related Documentation:
CRM Help Documentation: N/A
Send us your feedback: We're always looking for advice to help improve our Knowledge Base! Please let us know if this article was helpful or provide feedback on how we can improve your experience here.
Thank you