Overview:
A user raises conflicting Calls on CRM for iPad. Call Conflict Status icon displays on the Calls:

If the customer clicks on the Call Conflict Status icon, it is not actionable.
Root Cause:
This is expected behavior. Call Conflict Status icon is only actionable Online and on CRM for Windows. Online and on CRM for Windows it opens the Calendar of the Account.
Solution:
On CRM for iPad, the Call Conflict Status icon displays only to inform the user about conflicting Calls. It is not actionable.
Related Documentation:
CRM Help Documentation: Displaying Call Conflict Warning
Thank you