Overview:
While querying the Sent_Email_vod object, it is noticed that the Territory_vod field is null on multiple records.
Root Cause:
Territory_vod is not populated on the Sent_Email_vod object if there is no Territory match between the end-user and account.
Solution:
First, ensure the end-user profile has Read Field Level Security (FLS) to the Territory_vod field on the Sent_Email_vod object. Second, it is important to understand how the Sent_Email_vod.Territory_vod field is updated:
- If the User and Account are in more than one territory, the first territory from the User that matches a territory of the Account is used.
- If no match between User and Account exists, the Territory_vod field is not populated on the Sent Email record
Related Documentation:
N/A
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